Scheduled for 08, October, 2025 at 10:00 PM – 09, October, 2025 at 1:00 AM
Affects
IceHost
Under maintenance from 10:00 PM to 1:00 AM
EU - Nodes
Under maintenance from 10:00 PM to 1:00 AM
Completed
09, October, 2025 at 1:00 AMCompleted
09, October, 2025 at 1:00 AMMaintenance is now in progress
In progress
08, October, 2025 at 10:00 PMIn progress
08, October, 2025 at 10:00 PMMaintenance is now in progress
Planned
08, October, 2025 at 10:00 PMPlanned
08, October, 2025 at 10:00 PMNode migration to infrastructure with newer components is planned, which will enhance the quality of our services. During the migration, servers will be temporarily unavailable. With upgraded hardware, we anticipate improved performance and stability. Thank you for your understanding, and we apologize for any inconvenience.